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Lowering the Cost of Applicant Processing


Problem

"Our cost per hire is a significant expense to the Company.  We need to reduce it without compromising our ability to identify good hires."

 

Cause

Some costs, like personality and skill assessments, background checks and drug tests, and travel costs, are purchased and can only be reduced by decreasing their use.  Other costs involve staff time devoted to processing applicants through the firm's vetting process which can be reduced through automation. Conventional processes have an average failure rate of 46%; so the process, and its costs, have to be repeated over half the time.

 

Solution

Reduce overall costs by vetting, assessing, and rank-ordering candidates automatically, allowing staff to defer their involvement (and associated cost) in the process-from conducting interviews and reference checks-to only those candidates most likely to be hired.  Staff time devoted to sorting through resumes and applications, phone interviews, and multiple face-to-face interviews are significantly reduced with Acclaim.  Acclaim also minimizes the number of applicants entering the final, most expensive, stages of the vetting process.  Acclaim's continuous automated recruiting, brand improvement, and passive candidate appeal also reduce the need, and cost, of advertising, job board listings, agency fees, and so on.